bashmount-3.2.0.ebuild 607 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="A bash script that uses udisks to handle removable devices without dependencies on any GUI"
  5. HOMEPAGE="https://sourceforge.net/projects/bashmount/"
  6. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 x86"
  10. IUSE=""
  11. # sys-apps/util-linux -> lsblk
  12. RDEPEND="app-shells/bash
  13. sys-apps/dbus
  14. sys-apps/util-linux
  15. sys-fs/udisks:2
  16. virtual/eject"
  17. DEPEND=""
  18. src_install() {
  19. dobin ${PN}
  20. insinto /etc
  21. doins ${PN}.conf
  22. doman ${PN}.1
  23. dodoc NEWS
  24. }