cramfs-1.1.ebuild 668 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit toolchain-funcs
  5. DESCRIPTION="Linux filesystem designed to be simple, small, and to compress things well"
  6. HOMEPAGE="https://sourceforge.net/projects/cramfs/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ppc ~sparc x86"
  11. IUSE=""
  12. DEPEND="sys-libs/zlib"
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. sed -i '1i#include <sys/sysmacros.h>' mkcramfs.c || die #580196
  16. }
  17. src_compile() {
  18. emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
  19. }
  20. src_install() {
  21. into /
  22. dosbin mkcramfs cramfsck
  23. dodoc README NOTES
  24. }