diskdev_cmds-332.14.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2008 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="HFS and HFS+ utils ported from OSX, supplies mkfs and fsck"
  5. HOMEPAGE="http://opendarwin.org"
  6. SRC_URI="http://darwinsource.opendarwin.org/tarballs/apsl/diskdev_cmds-${PV}.tar.gz
  7. mirror://gentoo/diskdev_cmds-${PV}.patch.bz2"
  8. LICENSE="APSL-2"
  9. SLOT="0"
  10. KEYWORDS="-amd64 ~ppc ~x86"
  11. IUSE=""
  12. DEPEND=""
  13. src_unpack() {
  14. unpack ${A}
  15. cd "${S}"
  16. epatch "${WORKDIR}"/diskdev_cmds-${PV}.patch
  17. }
  18. src_compile() {
  19. emake -f Makefile.lnx || die "emake failed"
  20. }
  21. src_install() {
  22. exeinto /sbin
  23. doexe fsck_hfs.tproj/fsck_hfs
  24. doexe newfs_hfs.tproj/newfs_hfs
  25. dosym /sbin/newfs_hfs /sbin/mkfs.hfs
  26. dosym /sbin/newfs_hfs /sbin/mkfs.hfsplus
  27. dosym /sbin/fsck_hfs /sbin/fsck.hfs
  28. dosym /sbin/fsck_hfs /sbin/fsck.hfsplus
  29. doman newfs_hfs.tproj/newfs_hfs.8
  30. newman newfs_hfs.tproj/newfs_hfs.8 mkfs.hfs.8
  31. newman newfs_hfs.tproj/newfs_hfs.8 mkfs.hfsplus.8
  32. doman fsck_hfs.tproj/fsck_hfs.8
  33. newman fsck_hfs.tproj/fsck_hfs.8 fsck.hfs.8
  34. newman fsck_hfs.tproj/fsck_hfs.8 fsck.hfsplus.8
  35. }