dislocker-0.7.1.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils cmake-utils flag-o-matic
  5. DESCRIPTION="Dislocker is used to read BitLocker encrypted partitions."
  6. HOMEPAGE="https://github.com/Aorimn/dislocker"
  7. if [[ ${PV} == *9999* ]]; then
  8. EGIT_REPO_URI="https://github.com/Aorimn/dislocker.git"
  9. inherit git-r3
  10. else
  11. SRC_URI="https://github.com/Aorimn/dislocker/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  12. KEYWORDS="~x86 ~amd64"
  13. fi
  14. LICENSE="GPL-2"
  15. SLOT="0"
  16. IUSE="ruby"
  17. DEPEND="sys-fs/fuse
  18. || ( net-libs/polarssl net-libs/mbedtls )
  19. ruby? ( dev-lang/ruby:2.1 )"
  20. RDEPEND="${DEPEND}"
  21. src_prepare() {
  22. # We either need to change Werror to Wno-error or remove the multiple declarations of FORTIFY_SOURCE
  23. # sed 's:Werror:Wno-error:g' -i "${S}/src/CMakeLists.txt" || die
  24. sed 's:-D_FORTIFY_SOURCE=2::g' -i "${S}/src/CMakeLists.txt" || die
  25. sed 's:\.\./man:'../../${P}/man':g' -i "${S}/src/CMakeLists.txt" || die
  26. }
  27. src_configure() {
  28. mycmakeargs=(
  29. $(cmake-utils_use_find_package ruby Ruby)
  30. )
  31. cmake-utils_src_configure
  32. }
  33. src_install() {
  34. find "${S}/man/linux" -name '*.1' -exec doman '{}' +
  35. cmake-utils_src_install
  36. }