dmg2img-1.6.5.ebuild 660 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit toolchain-funcs
  5. DESCRIPTION="Converts Apple DMG files to standard HFS+ images"
  6. HOMEPAGE="http://vu1tur.eu.org/tools"
  7. SRC_URI="http://vu1tur.eu.org/tools/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. IUSE=""
  12. RDEPEND="dev-libs/openssl
  13. app-arch/bzip2
  14. sys-libs/zlib"
  15. DEPEND="${RDEPEND}
  16. sys-apps/sed"
  17. src_prepare() {
  18. sed -i -e 's:-s:$(LDFLAGS):g' Makefile || die "sed failed"
  19. }
  20. src_compile() {
  21. tc-export CC
  22. emake CFLAGS="${CFLAGS}"
  23. }
  24. src_install() {
  25. dobin dmg2img vfdecrypt
  26. dodoc README
  27. doman vfdecrypt.1
  28. }