duperemove-0.09.5.ebuild 734 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Btrfs deduplication utility"
  6. HOMEPAGE="https://github.com/markfasheh/duperemove"
  7. SRC_URI="https://github.com/markfasheh/duperemove/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE=""
  12. RDEPEND="dev-libs/glib:2=
  13. dev-libs/libgcrypt:0="
  14. DEPEND="${RDEPEND}"
  15. src_compile() {
  16. # CC & CFLAGS are set via = so need to override them
  17. # LIBRARY_FLAGS are set via += so need to pass them via env
  18. export LIBRARY_FLAGS="${LDFLAGS}"
  19. emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
  20. }
  21. src_install() {
  22. emake DESTDIR="${D}" PREFIX="/usr" install
  23. }