e4rat-0.2.4_pre20141201.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils linux-info readme.gentoo-r1
  5. DESCRIPTION="Toolset to accelerate the boot process and application startup"
  6. HOMEPAGE="http://e4rat.sourceforge.net/"
  7. #SRC_URI="mirror://sourceforge/${PN}/${P/-/_}_src.tar.gz"
  8. SRC_URI="https://dev.gentoo.org/~pacho/${PN}/${PN}-0.2.4_pre20141201.tar.xz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE=""
  13. RDEPEND="
  14. dev-lang/perl:=
  15. >=dev-libs/boost-1.42:=
  16. sys-fs/e2fsprogs
  17. sys-process/audit[static-libs(+)]
  18. sys-process/lsof
  19. "
  20. DEPEND="${DEPEND}"
  21. CONFIG_CHECK="~AUDITSYSCALL"
  22. PATCHES=(
  23. "${FILESDIR}"/${PN}-0.2.2-shared-build.patch
  24. "${FILESDIR}"/${PN}-0.2.2-libdir.patch
  25. "${FILESDIR}"/${PN}-0.2.4-sysmacros.patch #580534
  26. "${FILESDIR}"/${PN}-0.2.4-gcc6.patch #594046
  27. )
  28. pkg_setup() {
  29. check_extra_config
  30. DOC_CONTENTS="
  31. To launch systemd from e4rat you simply need to edit /etc/e4rat.conf
  32. and set:\n
  33. ; path to init process binary (DEFAULT: /sbin/init)\n
  34. init /usr/lib/systemd/systemd"
  35. }
  36. src_install() {
  37. cmake-utils_src_install
  38. # relocate binaries to /sbin. If someone knows of a better way to do it
  39. # please do tell me
  40. dodir sbin
  41. find "${D}"/usr/sbin -type f -exec mv {} "${D}"/sbin/. \; \
  42. || die
  43. readme.gentoo_create_doc
  44. }
  45. pkg_postinst() {
  46. readme.gentoo_print_elog
  47. if has_version sys-apps/preload; then
  48. elog "It appears you have sys-apps/preload installed. This may"
  49. elog "has negative effects on ${PN}. You may want to disable preload"
  50. elog "when using ${PN}."
  51. fi
  52. }