f2fs-tools-1.6.0.ebuild 660 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit multilib
  5. DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
  6. HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/jaegeuk/f2fs-tools.git;a=summary"
  7. SRC_URI="https://dev.gentoo.org/~blueness/f2fs-tools/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0/0"
  10. KEYWORDS="amd64 arm ~mips ppc ppc64 x86"
  11. IUSE=""
  12. src_configure() {
  13. #This is required to install to /sbin, bug #481110
  14. econf --prefix=/ --includedir=/usr/include
  15. }
  16. src_install() {
  17. default
  18. rm -f "${ED}"/$(get_libdir)/libf2fs.{,l}a
  19. rm -f "${ED}"/$(get_libdir)/libf2fs_format.{,l}a
  20. }