f2fs-tools-1.6.1.ebuild 737 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit multilib eutils
  5. DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
  6. HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/jaegeuk/f2fs-tools.git;a=summary"
  7. SRC_URI="https://dev.gentoo.org/~blueness/f2fs-tools/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0/0"
  10. KEYWORDS="amd64 arm ~mips ppc ppc64 x86"
  11. IUSE=""
  12. src_prepare() {
  13. epatch "${FILESDIR}"/${P}-sysmacros.patch #580338
  14. }
  15. src_configure() {
  16. #This is required to install to /sbin, bug #481110
  17. econf --prefix=/ --includedir=/usr/include
  18. }
  19. src_install() {
  20. default
  21. rm -f "${ED}"/$(get_libdir)/libf2fs.{,l}a
  22. rm -f "${ED}"/$(get_libdir)/libf2fs_format.{,l}a
  23. }