f2fs-tools-1.7.0-r1.ebuild 667 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
  5. HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
  6. SRC_URI="https://dev.gentoo.org/~blueness/f2fs-tools/${P}.tar.xz"
  7. LICENSE="GPL-2"
  8. SLOT="0/1"
  9. KEYWORDS="~amd64 ~arm ~mips ~x86"
  10. IUSE=""
  11. RDEPEND="
  12. sys-apps/util-linux
  13. sys-libs/libselinux"
  14. DEPEND="$RDEPEND"
  15. src_configure() {
  16. #This is required to install to /sbin, bug #481110
  17. econf \
  18. --bindir="${EPREFIX}"/sbin
  19. --disable-static
  20. }
  21. src_install() {
  22. default
  23. find "${D}" -name "*.la" -delete || die
  24. }