iprutils-2.4.13.1.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools bash-completion-r1 eutils toolchain-funcs
  5. DESCRIPTION="IBM's tools for support of the ipr SCSI controller"
  6. SRC_URI="mirror://sourceforge/iprdd/${P}.tar.gz"
  7. HOMEPAGE="https://sourceforge.net/projects/iprdd/"
  8. SLOT="0"
  9. LICENSE="IBM"
  10. KEYWORDS="~ppc ~ppc64"
  11. IUSE="static-libs"
  12. IPRUTILS_DEPEND="
  13. >=sys-libs/ncurses-5.4-r5:=
  14. >=sys-apps/pciutils-2.1.11-r1
  15. "
  16. RDEPEND="
  17. ${IPRUTILS_DEPEND}
  18. virtual/logger
  19. virtual/udev
  20. "
  21. DEPEND="
  22. ${IPRUTILS_DEPEND}
  23. virtual/pkgconfig
  24. "
  25. PATCHES=(
  26. "${FILESDIR}"/${PN}-2.4.8-tinfo.patch
  27. "${FILESDIR}"/${PN}-2.4.11.1-basename.patch
  28. "${FILESDIR}"/${PN}-2.4.11.1-migrate_cand.patch
  29. )
  30. src_prepare() {
  31. default
  32. eautoreconf
  33. }
  34. src_configure() {
  35. econf $(use_enable static-libs static)
  36. }
  37. src_install () {
  38. emake DESTDIR="${D}" \
  39. bashcompdir=$(get_bashcompdir) install
  40. newinitd "${FILESDIR}"/iprinit-r1 iprinit
  41. newinitd "${FILESDIR}"/iprupdate-r1 iprupdate
  42. newinitd "${FILESDIR}"/iprdump-r1 iprdump
  43. prune_libtool_files
  44. }