iprutils-2.4.7.ebuild 835 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils toolchain-funcs
  5. DESCRIPTION="IBM's tools for support of the ipr SCSI controller"
  6. SRC_URI="mirror://sourceforge/iprdd/${P}.tar.gz"
  7. HOMEPAGE="https://sourceforge.net/projects/iprdd/"
  8. SLOT="0"
  9. LICENSE="IBM"
  10. KEYWORDS="ppc ppc64"
  11. IUSE="static-libs"
  12. DEPEND="
  13. >=sys-libs/ncurses-5.4-r5
  14. >=sys-apps/pciutils-2.1.11-r1
  15. virtual/udev
  16. "
  17. RDEPEND="
  18. ${DEPEND}
  19. virtual/logger
  20. "
  21. src_prepare() {
  22. epatch "${FILESDIR}"/${PN}-2.4.7-tinfo.patch
  23. eautoreconf
  24. }
  25. src_configure() {
  26. econf $(use_enable static-libs static)
  27. }
  28. src_install () {
  29. default
  30. newinitd "${FILESDIR}"/iprinit-r1 iprinit
  31. newinitd "${FILESDIR}"/iprupdate-r1 iprupdate
  32. newinitd "${FILESDIR}"/iprdump-r1 iprdump
  33. prune_libtool_files
  34. }