lvm2-2.02.116-r4.ebuild 9.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils linux-info multilib systemd toolchain-funcs udev flag-o-matic
  5. DESCRIPTION="User-land utilities for LVM2 (device-mapper) software"
  6. HOMEPAGE="https://sourceware.org/lvm2/"
  7. SRC_URI="ftp://sourceware.org/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz
  8. ftp://sourceware.org/pub/lvm2/old/${PN/lvm/LVM}.${PV}.tgz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
  12. IUSE="readline static static-libs systemd clvm cman lvm1 lvm2create_initrd selinux +udev +thin device-mapper-only"
  13. REQUIRED_USE="device-mapper-only? ( !clvm !cman !lvm1 !lvm2create_initrd !thin )
  14. systemd? ( udev )
  15. clvm? ( !systemd )"
  16. DEPEND_COMMON="clvm? ( cman? ( =sys-cluster/cman-3* ) =sys-cluster/libdlm-3* )
  17. readline? ( sys-libs/readline:0= )
  18. udev? ( >=virtual/libudev-208:=[static-libs?] )"
  19. # /run is now required for locking during early boot. /var cannot be assumed to
  20. # be available -- thus, pull in recent enough baselayout for /run.
  21. # This version of LVM is incompatible with cryptsetup <1.1.2.
  22. RDEPEND="${DEPEND_COMMON}
  23. >=sys-apps/baselayout-2.2
  24. !<sys-apps/openrc-0.11
  25. !<sys-fs/cryptsetup-1.1.2
  26. !!sys-fs/clvm
  27. !!sys-fs/lvm-user
  28. >=sys-apps/util-linux-2.16
  29. lvm2create_initrd? (
  30. app-arch/cpio
  31. sys-apps/makedev
  32. )
  33. thin? ( >=sys-block/thin-provisioning-tools-0.3.0 )"
  34. # note: thin- 0.3.0 is required to avoid --disable-thin_check_needs_check
  35. # USE 'static' currently only works with eudev, bug 520450
  36. DEPEND="${DEPEND_COMMON}
  37. virtual/pkgconfig
  38. >=sys-devel/binutils-2.20.1-r1
  39. static? (
  40. selinux? ( sys-libs/libselinux[static-libs] )
  41. udev? ( >=sys-fs/eudev-3.1.2[static-libs] )
  42. >=sys-apps/util-linux-2.16[static-libs]
  43. )"
  44. S=${WORKDIR}/${PN/lvm/LVM}.${PV}
  45. pkg_setup() {
  46. local CONFIG_CHECK="~SYSVIPC"
  47. if use udev; then
  48. local WARNING_SYSVIPC="CONFIG_SYSVIPC:\tis not set (required for udev sync)\n"
  49. if linux_config_exists; then
  50. local uevent_helper_path=$(linux_chkconfig_string UEVENT_HELPER_PATH)
  51. if [ -n "${uevent_helper_path}" ] && [ "${uevent_helper_path}" != '""' ]; then
  52. ewarn "It's recommended to set an empty value to the following kernel config option:"
  53. ewarn "CONFIG_UEVENT_HELPER_PATH=${uevent_helper_path}"
  54. fi
  55. fi
  56. fi
  57. check_extra_config
  58. # 1. Genkernel no longer copies /sbin/lvm blindly.
  59. if use static; then
  60. elog "Warning, we no longer overwrite /sbin/lvm and /sbin/dmsetup with"
  61. elog "their static versions. If you need the static binaries,"
  62. elog "you must append .static to the filename!"
  63. fi
  64. }
  65. src_prepare() {
  66. # Gentoo specific modification(s):
  67. epatch "${FILESDIR}"/${PN}-2.02.108-example.conf.in.patch
  68. sed -i \
  69. -e "1iAR = $(tc-getAR)" \
  70. -e "s:CC ?= @CC@:CC = $(tc-getCC):" \
  71. make.tmpl.in || die #444082
  72. sed -i -e '/FLAG/s:-O2::' configure{.in,} || die #480212
  73. if use udev && ! use device-mapper-only; then
  74. sed -i -e '/use_lvmetad =/s:0:1:' conf/example.conf.in || die #514196
  75. elog "Notice that \"use_lvmetad\" setting is enabled with USE=\"udev\" in"
  76. elog "/etc/lvm/lvm.conf, which will require restart of udev, lvm, and lvmetad"
  77. elog "if it was previously disabled."
  78. fi
  79. sed -i -e "s:/usr/bin/true:$(type -P true):" scripts/blk_availability_systemd_red_hat.service.in || die #517514
  80. # For upstream -- review and forward:
  81. epatch "${FILESDIR}"/${PN}-2.02.63-always-make-static-libdm.patch
  82. epatch "${FILESDIR}"/${PN}-2.02.56-lvm2create_initrd.patch
  83. epatch "${FILESDIR}"/${PN}-2.02.67-createinitrd.patch #301331
  84. epatch "${FILESDIR}"/${PN}-2.02.99-locale-muck.patch #330373
  85. epatch "${FILESDIR}"/${PN}-2.02.70-asneeded.patch # -Wl,--as-needed
  86. epatch "${FILESDIR}"/${PN}-2.02.92-dynamic-static-ldflags.patch #332905
  87. epatch "${FILESDIR}"/${PN}-2.02.108-static-pkgconfig-libs.patch #370217, #439414 + blkid
  88. epatch "${FILESDIR}"/${PN}-2.02.106-pthread-pkgconfig.patch #492450
  89. # Without thin-privision-tools, there is nothing to install for target install_man7:
  90. use thin || { sed -i -e '/^install_lvm2/s:install_man7::' man/Makefile.in || die; }
  91. eautoreconf
  92. }
  93. src_configure() {
  94. filter-flags -flto
  95. local myconf
  96. local buildmode
  97. myconf="${myconf} $(use_enable !device-mapper-only dmeventd)"
  98. myconf="${myconf} $(use_enable !device-mapper-only cmdlib)"
  99. myconf="${myconf} $(use_enable !device-mapper-only applib)"
  100. myconf="${myconf} $(use_enable !device-mapper-only fsadm)"
  101. myconf="${myconf} $(use_enable !device-mapper-only lvmetad)"
  102. use device-mapper-only && myconf="${myconf} --disable-udev-systemd-background-jobs"
  103. # Most of this package does weird stuff.
  104. # The build options are tristate, and --without is NOT supported
  105. # options: 'none', 'internal', 'shared'
  106. if use static; then
  107. buildmode="internal"
  108. # This only causes the .static versions to become available
  109. myconf="${myconf} --enable-static_link"
  110. else
  111. buildmode="shared"
  112. fi
  113. dmbuildmode=$(use !device-mapper-only && echo internal || echo none)
  114. # dmeventd requires mirrors to be internal, and snapshot available
  115. # so we cannot disable them
  116. myconf="${myconf} --with-mirrors=${dmbuildmode}"
  117. myconf="${myconf} --with-snapshots=${dmbuildmode}"
  118. if use thin; then
  119. myconf="${myconf} --with-thin=internal --with-cache=internal"
  120. local texec
  121. for texec in check dump repair restore; do
  122. myconf="${myconf} --with-thin-${texec}=${EPREFIX}/sbin/thin_${texec}"
  123. myconf="${myconf} --with-cache-${texec}=${EPREFIX}/sbin/cache_${texec}"
  124. done
  125. else
  126. myconf="${myconf} --with-thin=none --with-cache=none"
  127. fi
  128. if use lvm1; then
  129. myconf="${myconf} --with-lvm1=${buildmode}"
  130. else
  131. myconf="${myconf} --with-lvm1=none"
  132. fi
  133. # disable O_DIRECT support on hppa, breaks pv detection (#99532)
  134. use hppa && myconf="${myconf} --disable-o_direct"
  135. if use clvm; then
  136. myconf="${myconf} --with-cluster=${buildmode}"
  137. # 4-state! Make sure we get it right, per bug 210879
  138. # Valid options are: none, cman, gulm, all
  139. #
  140. # 2009/02:
  141. # gulm is removed now, now dual-state:
  142. # cman, none
  143. # all still exists, but is not needed
  144. #
  145. # 2009/07:
  146. # TODO: add corosync and re-enable ALL
  147. local clvmd=""
  148. use cman && clvmd="cman"
  149. #clvmd="${clvmd/cmangulm/all}"
  150. [ -z "${clvmd}" ] && clvmd="none"
  151. myconf="${myconf} --with-clvmd=${clvmd}"
  152. myconf="${myconf} --with-pool=${buildmode}"
  153. else
  154. myconf="${myconf} --with-clvmd=none --with-cluster=none"
  155. fi
  156. econf \
  157. $(use_enable readline) \
  158. $(use_enable selinux) \
  159. --enable-pkgconfig \
  160. --with-confdir="${EPREFIX}"/etc \
  161. --exec-prefix="${EPREFIX}" \
  162. --sbindir="${EPREFIX}/sbin" \
  163. --with-staticdir="${EPREFIX}"/sbin \
  164. --libdir="${EPREFIX}/$(get_libdir)" \
  165. --with-usrlibdir="${EPREFIX}/usr/$(get_libdir)" \
  166. --with-default-dm-run-dir=/run \
  167. --with-default-run-dir=/run/lvm \
  168. --with-default-locking-dir=/run/lock/lvm \
  169. --with-default-pid-dir=/run \
  170. $(use_enable udev udev_rules) \
  171. $(use_enable udev udev_sync) \
  172. $(use_with udev udevdir "$(get_udevdir)"/rules.d) \
  173. $(use_enable systemd udev-systemd-background-jobs) \
  174. "$(systemd_with_unitdir)" \
  175. ${myconf} \
  176. CLDFLAGS="${LDFLAGS}"
  177. }
  178. src_compile() {
  179. pushd include >/dev/null
  180. emake
  181. popd >/dev/null
  182. if use device-mapper-only ; then
  183. emake device-mapper
  184. else
  185. emake
  186. emake CC="$(tc-getCC)" -C scripts lvm2_activation_generator_systemd_red_hat
  187. fi
  188. }
  189. src_install() {
  190. local inst
  191. INSTALL_TARGETS="install install_tmpfiles_configuration"
  192. # install systemd related files only when requested, bug #522430
  193. use systemd && INSTALL_TARGETS="${INSTALL_TARGETS} install_systemd_units install_systemd_generators"
  194. use device-mapper-only && INSTALL_TARGETS="install_device-mapper"
  195. for inst in ${INSTALL_TARGETS}; do
  196. emake DESTDIR="${D}" ${inst}
  197. done
  198. newinitd "${FILESDIR}"/device-mapper.rc-2.02.105-r2 device-mapper
  199. newconfd "${FILESDIR}"/device-mapper.conf-1.02.22-r3 device-mapper
  200. if use !device-mapper-only ; then
  201. newinitd "${FILESDIR}"/dmeventd.initd-2.02.67-r1 dmeventd
  202. newinitd "${FILESDIR}"/lvm.rc-2.02.116-r4 lvm
  203. newconfd "${FILESDIR}"/lvm.confd-2.02.28-r2 lvm
  204. newinitd "${FILESDIR}"/lvm-monitoring.initd-2.02.105-r2 lvm-monitoring
  205. newinitd "${FILESDIR}"/lvmetad.initd-2.02.116-r3 lvmetad
  206. fi
  207. if use clvm; then
  208. newinitd "${FILESDIR}"/clvmd.rc-2.02.39 clvmd
  209. newconfd "${FILESDIR}"/clvmd.confd-2.02.39 clvmd
  210. fi
  211. if use static-libs; then
  212. dolib.a libdm/ioctl/libdevmapper.a
  213. dolib.a libdaemon/client/libdaemonclient.a #462908
  214. #gen_usr_ldscript libdevmapper.so
  215. dolib.a daemons/dmeventd/libdevmapper-event.a
  216. #gen_usr_ldscript libdevmapper-event.so
  217. else
  218. rm -f "${ED}"usr/$(get_libdir)/{libdevmapper-event,liblvm2cmd,liblvm2app,libdevmapper}.a
  219. fi
  220. if use lvm2create_initrd; then
  221. dosbin scripts/lvm2create_initrd/lvm2create_initrd
  222. doman scripts/lvm2create_initrd/lvm2create_initrd.8
  223. newdoc scripts/lvm2create_initrd/README README.lvm2create_initrd
  224. fi
  225. insinto /etc
  226. doins "${FILESDIR}"/dmtab
  227. dodoc README VERSION* WHATS_NEW WHATS_NEW_DM doc/*.{c,txt} conf/*.conf
  228. }
  229. pkg_postinst() {
  230. ewarn "Make sure the \"lvm\" init script is in the runlevels:"
  231. ewarn "# rc-update add lvm boot"
  232. ewarn
  233. ewarn "Make sure to enable lvmetad in /etc/lvm/lvm.conf if you want"
  234. ewarn "to enable lvm autoactivation and metadata caching."
  235. ewarn
  236. ewarn "After enabling or disabling lvmetad in /etc/lvm/lvm.conf you must"
  237. ewarn "run the following to update the init script dependencies: "
  238. ewarn "# rc-update -u"
  239. }
  240. src_test() {
  241. einfo "Tests are disabled because of device-node mucking, if you want to"
  242. einfo "run tests, compile the package and see ${S}/tests"
  243. }