lvm2-2.02.116-r5.ebuild 9.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils linux-info multilib systemd toolchain-funcs udev flag-o-matic
  5. DESCRIPTION="User-land utilities for LVM2 (device-mapper) software"
  6. HOMEPAGE="https://sourceware.org/lvm2/"
  7. SRC_URI="ftp://sourceware.org/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz
  8. ftp://sourceware.org/pub/lvm2/old/${PN/lvm/LVM}.${PV}.tgz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
  12. IUSE="readline static static-libs systemd clvm cman corosync lvm1 lvm2create_initrd openais selinux +udev +thin device-mapper-only"
  13. REQUIRED_USE="device-mapper-only? ( !clvm !cman !corosync !lvm1 !lvm2create_initrd !openais !thin )
  14. systemd? ( udev )
  15. clvm? ( !systemd )"
  16. DEPEND_COMMON="
  17. clvm? (
  18. cman? ( =sys-cluster/cman-3* )
  19. corosync? ( sys-cluster/corosync )
  20. openais? ( sys-cluster/openais )
  21. =sys-cluster/libdlm-3*
  22. )
  23. readline? ( sys-libs/readline:0= )
  24. udev? ( >=virtual/libudev-208:=[static-libs?] )"
  25. # /run is now required for locking during early boot. /var cannot be assumed to
  26. # be available -- thus, pull in recent enough baselayout for /run.
  27. # This version of LVM is incompatible with cryptsetup <1.1.2.
  28. RDEPEND="${DEPEND_COMMON}
  29. >=sys-apps/baselayout-2.2
  30. !<sys-apps/openrc-0.11
  31. !<sys-fs/cryptsetup-1.1.2
  32. !!sys-fs/clvm
  33. !!sys-fs/lvm-user
  34. >=sys-apps/util-linux-2.16
  35. lvm2create_initrd? (
  36. app-arch/cpio
  37. sys-apps/makedev
  38. )
  39. thin? ( >=sys-block/thin-provisioning-tools-0.3.0 )"
  40. # note: thin- 0.3.0 is required to avoid --disable-thin_check_needs_check
  41. # USE 'static' currently only works with eudev, bug 520450
  42. DEPEND="${DEPEND_COMMON}
  43. virtual/pkgconfig
  44. >=sys-devel/binutils-2.20.1-r1
  45. static? (
  46. selinux? ( sys-libs/libselinux[static-libs] )
  47. udev? ( >=sys-fs/eudev-3.1.2[static-libs] )
  48. >=sys-apps/util-linux-2.16[static-libs]
  49. )"
  50. S=${WORKDIR}/${PN/lvm/LVM}.${PV}
  51. pkg_setup() {
  52. local CONFIG_CHECK="~SYSVIPC"
  53. if use udev; then
  54. local WARNING_SYSVIPC="CONFIG_SYSVIPC:\tis not set (required for udev sync)\n"
  55. if linux_config_exists; then
  56. local uevent_helper_path=$(linux_chkconfig_string UEVENT_HELPER_PATH)
  57. if [ -n "${uevent_helper_path}" ] && [ "${uevent_helper_path}" != '""' ]; then
  58. ewarn "It's recommended to set an empty value to the following kernel config option:"
  59. ewarn "CONFIG_UEVENT_HELPER_PATH=${uevent_helper_path}"
  60. fi
  61. fi
  62. fi
  63. check_extra_config
  64. # 1. Genkernel no longer copies /sbin/lvm blindly.
  65. if use static; then
  66. elog "Warning, we no longer overwrite /sbin/lvm and /sbin/dmsetup with"
  67. elog "their static versions. If you need the static binaries,"
  68. elog "you must append .static to the filename!"
  69. fi
  70. }
  71. src_prepare() {
  72. # Gentoo specific modification(s):
  73. epatch "${FILESDIR}"/${PN}-2.02.108-example.conf.in.patch
  74. sed -i \
  75. -e "1iAR = $(tc-getAR)" \
  76. -e "s:CC ?= @CC@:CC = $(tc-getCC):" \
  77. make.tmpl.in || die #444082
  78. sed -i -e '/FLAG/s:-O2::' configure{.in,} || die #480212
  79. if use udev && ! use device-mapper-only; then
  80. sed -i -e '/use_lvmetad =/s:0:1:' conf/example.conf.in || die #514196
  81. elog "Notice that \"use_lvmetad\" setting is enabled with USE=\"udev\" in"
  82. elog "/etc/lvm/lvm.conf, which will require restart of udev, lvm, and lvmetad"
  83. elog "if it was previously disabled."
  84. fi
  85. sed -i -e "s:/usr/bin/true:$(type -P true):" scripts/blk_availability_systemd_red_hat.service.in || die #517514
  86. # For upstream -- review and forward:
  87. epatch "${FILESDIR}"/${PN}-2.02.63-always-make-static-libdm.patch
  88. epatch "${FILESDIR}"/${PN}-2.02.56-lvm2create_initrd.patch
  89. epatch "${FILESDIR}"/${PN}-2.02.67-createinitrd.patch #301331
  90. epatch "${FILESDIR}"/${PN}-2.02.99-locale-muck.patch #330373
  91. epatch "${FILESDIR}"/${PN}-2.02.70-asneeded.patch # -Wl,--as-needed
  92. epatch "${FILESDIR}"/${PN}-2.02.92-dynamic-static-ldflags.patch #332905
  93. epatch "${FILESDIR}"/${PN}-2.02.108-static-pkgconfig-libs.patch #370217, #439414 + blkid
  94. epatch "${FILESDIR}"/${PN}-2.02.106-pthread-pkgconfig.patch #492450
  95. # Without thin-privision-tools, there is nothing to install for target install_man7:
  96. use thin || { sed -i -e '/^install_lvm2/s:install_man7::' man/Makefile.in || die; }
  97. eautoreconf
  98. }
  99. src_configure() {
  100. filter-flags -flto
  101. local myconf
  102. local buildmode
  103. myconf="${myconf} $(use_enable !device-mapper-only dmeventd)"
  104. myconf="${myconf} $(use_enable !device-mapper-only cmdlib)"
  105. myconf="${myconf} $(use_enable !device-mapper-only applib)"
  106. myconf="${myconf} $(use_enable !device-mapper-only fsadm)"
  107. myconf="${myconf} $(use_enable !device-mapper-only lvmetad)"
  108. use device-mapper-only && myconf="${myconf} --disable-udev-systemd-background-jobs"
  109. # Most of this package does weird stuff.
  110. # The build options are tristate, and --without is NOT supported
  111. # options: 'none', 'internal', 'shared'
  112. if use static; then
  113. buildmode="internal"
  114. # This only causes the .static versions to become available
  115. myconf="${myconf} --enable-static_link"
  116. else
  117. buildmode="shared"
  118. fi
  119. dmbuildmode=$(use !device-mapper-only && echo internal || echo none)
  120. # dmeventd requires mirrors to be internal, and snapshot available
  121. # so we cannot disable them
  122. myconf="${myconf} --with-mirrors=${dmbuildmode}"
  123. myconf="${myconf} --with-snapshots=${dmbuildmode}"
  124. if use thin; then
  125. myconf="${myconf} --with-thin=internal --with-cache=internal"
  126. local texec
  127. for texec in check dump repair restore; do
  128. myconf="${myconf} --with-thin-${texec}=${EPREFIX}/sbin/thin_${texec}"
  129. myconf="${myconf} --with-cache-${texec}=${EPREFIX}/sbin/cache_${texec}"
  130. done
  131. else
  132. myconf="${myconf} --with-thin=none --with-cache=none"
  133. fi
  134. if use lvm1; then
  135. myconf="${myconf} --with-lvm1=${buildmode}"
  136. else
  137. myconf="${myconf} --with-lvm1=none"
  138. fi
  139. # disable O_DIRECT support on hppa, breaks pv detection (#99532)
  140. use hppa && myconf="${myconf} --disable-o_direct"
  141. if use clvm; then
  142. myconf="${myconf} --with-cluster=${buildmode}"
  143. # 4-state! Make sure we get it right, per bug 210879
  144. # Valid options are: none, cman, gulm, all
  145. #
  146. # 2009/02:
  147. # gulm is removed now, now dual-state:
  148. # cman, none
  149. # all still exists, but is not needed
  150. #
  151. # 2009/07:
  152. # TODO: add corosync and re-enable ALL
  153. local clvmd=""
  154. use cman && clvmd="cman"
  155. #clvmd="${clvmd/cmangulm/all}"
  156. use corosync && clvmd="${clvmd:+$clvmd,}corosync"
  157. use openais && clvmd="${clvmd:+$clvmd,}openais"
  158. [ -z "${clvmd}" ] && clvmd="none"
  159. myconf="${myconf} --with-clvmd=${clvmd}"
  160. myconf="${myconf} --with-pool=${buildmode}"
  161. else
  162. myconf="${myconf} --with-clvmd=none --with-cluster=none"
  163. fi
  164. econf \
  165. $(use_enable readline) \
  166. $(use_enable selinux) \
  167. --enable-pkgconfig \
  168. --with-confdir="${EPREFIX}"/etc \
  169. --exec-prefix="${EPREFIX}" \
  170. --sbindir="${EPREFIX}/sbin" \
  171. --with-staticdir="${EPREFIX}"/sbin \
  172. --libdir="${EPREFIX}/$(get_libdir)" \
  173. --with-usrlibdir="${EPREFIX}/usr/$(get_libdir)" \
  174. --with-default-dm-run-dir=/run \
  175. --with-default-run-dir=/run/lvm \
  176. --with-default-locking-dir=/run/lock/lvm \
  177. --with-default-pid-dir=/run \
  178. $(use_enable udev udev_rules) \
  179. $(use_enable udev udev_sync) \
  180. $(use_with udev udevdir "$(get_udevdir)"/rules.d) \
  181. $(use_enable systemd udev-systemd-background-jobs) \
  182. "$(systemd_with_unitdir)" \
  183. ${myconf} \
  184. CLDFLAGS="${LDFLAGS}"
  185. }
  186. src_compile() {
  187. pushd include >/dev/null
  188. emake
  189. popd >/dev/null
  190. if use device-mapper-only ; then
  191. emake device-mapper
  192. else
  193. emake
  194. emake CC="$(tc-getCC)" -C scripts lvm2_activation_generator_systemd_red_hat
  195. fi
  196. }
  197. src_install() {
  198. local inst
  199. INSTALL_TARGETS="install install_tmpfiles_configuration"
  200. # install systemd related files only when requested, bug #522430
  201. use systemd && INSTALL_TARGETS="${INSTALL_TARGETS} install_systemd_units install_systemd_generators"
  202. use device-mapper-only && INSTALL_TARGETS="install_device-mapper"
  203. for inst in ${INSTALL_TARGETS}; do
  204. emake DESTDIR="${D}" ${inst}
  205. done
  206. newinitd "${FILESDIR}"/device-mapper.rc-2.02.105-r2 device-mapper
  207. newconfd "${FILESDIR}"/device-mapper.conf-1.02.22-r3 device-mapper
  208. if use !device-mapper-only ; then
  209. newinitd "${FILESDIR}"/dmeventd.initd-2.02.67-r1 dmeventd
  210. newinitd "${FILESDIR}"/lvm.rc-2.02.116-r4 lvm
  211. newconfd "${FILESDIR}"/lvm.confd-2.02.28-r2 lvm
  212. newinitd "${FILESDIR}"/lvm-monitoring.initd-2.02.105-r2 lvm-monitoring
  213. newinitd "${FILESDIR}"/lvmetad.initd-2.02.116-r3 lvmetad
  214. fi
  215. if use clvm; then
  216. newinitd "${FILESDIR}"/clvmd.rc-2.02.39 clvmd
  217. newconfd "${FILESDIR}"/clvmd.confd-2.02.39 clvmd
  218. fi
  219. if use static-libs; then
  220. dolib.a libdm/ioctl/libdevmapper.a
  221. dolib.a libdaemon/client/libdaemonclient.a #462908
  222. #gen_usr_ldscript libdevmapper.so
  223. dolib.a daemons/dmeventd/libdevmapper-event.a
  224. #gen_usr_ldscript libdevmapper-event.so
  225. else
  226. rm -f "${ED}"usr/$(get_libdir)/{libdevmapper-event,liblvm2cmd,liblvm2app,libdevmapper}.a
  227. fi
  228. if use lvm2create_initrd; then
  229. dosbin scripts/lvm2create_initrd/lvm2create_initrd
  230. doman scripts/lvm2create_initrd/lvm2create_initrd.8
  231. newdoc scripts/lvm2create_initrd/README README.lvm2create_initrd
  232. fi
  233. insinto /etc
  234. doins "${FILESDIR}"/dmtab
  235. dodoc README VERSION* WHATS_NEW WHATS_NEW_DM doc/*.{c,txt} conf/*.conf
  236. }
  237. pkg_postinst() {
  238. ewarn "Make sure the \"lvm\" init script is in the runlevels:"
  239. ewarn "# rc-update add lvm boot"
  240. ewarn
  241. ewarn "Make sure to enable lvmetad in /etc/lvm/lvm.conf if you want"
  242. ewarn "to enable lvm autoactivation and metadata caching."
  243. ewarn
  244. ewarn "After enabling or disabling lvmetad in /etc/lvm/lvm.conf you must"
  245. ewarn "run the following to update the init script dependencies: "
  246. ewarn "# rc-update -u"
  247. }
  248. src_test() {
  249. einfo "Tests are disabled because of device-node mucking, if you want to"
  250. einfo "run tests, compile the package and see ${S}/tests"
  251. }