lvm2-2.02.145-r1.ebuild 9.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools eutils linux-info multilib systemd toolchain-funcs udev flag-o-matic
  5. DESCRIPTION="User-land utilities for LVM2 (device-mapper) software"
  6. HOMEPAGE="https://sourceware.org/lvm2/"
  7. SRC_URI="ftp://sourceware.org/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz
  8. ftp://sourceware.org/pub/lvm2/old/${PN/lvm/LVM}.${PV}.tgz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
  12. IUSE="readline static static-libs systemd clvm cman corosync lvm1 lvm2create_initrd openais selinux +udev +thin device-mapper-only"
  13. REQUIRED_USE="device-mapper-only? ( !clvm !cman !corosync !lvm1 !lvm2create_initrd !openais !thin )
  14. systemd? ( udev )
  15. clvm? ( !systemd )"
  16. DEPEND_COMMON="
  17. clvm? (
  18. cman? ( =sys-cluster/cman-3* )
  19. corosync? ( sys-cluster/corosync )
  20. openais? ( sys-cluster/openais )
  21. =sys-cluster/libdlm-3*
  22. )
  23. readline? ( sys-libs/readline:0= )
  24. udev? ( >=virtual/libudev-208:=[static-libs?] )"
  25. # /run is now required for locking during early boot. /var cannot be assumed to
  26. # be available -- thus, pull in recent enough baselayout for /run.
  27. # This version of LVM is incompatible with cryptsetup <1.1.2.
  28. RDEPEND="${DEPEND_COMMON}
  29. >=sys-apps/baselayout-2.2
  30. !<sys-apps/openrc-0.11
  31. !<sys-fs/cryptsetup-1.1.2
  32. !!sys-fs/clvm
  33. !!sys-fs/lvm-user
  34. >=sys-apps/util-linux-2.16
  35. lvm2create_initrd? ( sys-apps/makedev )
  36. thin? ( >=sys-block/thin-provisioning-tools-0.3.0 )"
  37. # note: thin- 0.3.0 is required to avoid --disable-thin_check_needs_check
  38. # USE 'static' currently only works with eudev, bug 520450
  39. DEPEND="${DEPEND_COMMON}
  40. virtual/pkgconfig
  41. >=sys-devel/binutils-2.20.1-r1
  42. sys-devel/autoconf-archive
  43. static? (
  44. selinux? ( sys-libs/libselinux[static-libs] )
  45. udev? ( >=sys-fs/eudev-3.1.2[static-libs] )
  46. >=sys-apps/util-linux-2.16[static-libs]
  47. )"
  48. S=${WORKDIR}/${PN/lvm/LVM}.${PV}
  49. PATCHES=(
  50. # Gentoo specific modification(s):
  51. "${FILESDIR}"/${PN}-2.02.129-example.conf.in.patch
  52. # For upstream -- review and forward:
  53. "${FILESDIR}"/${PN}-2.02.63-always-make-static-libdm.patch
  54. "${FILESDIR}"/${PN}-2.02.56-lvm2create_initrd.patch
  55. "${FILESDIR}"/${PN}-2.02.67-createinitrd.patch #301331
  56. "${FILESDIR}"/${PN}-2.02.99-locale-muck.patch #330373
  57. "${FILESDIR}"/${PN}-2.02.70-asneeded.patch # -Wl,--as-needed
  58. "${FILESDIR}"/${PN}-2.02.139-dynamic-static-ldflags.patch #332905
  59. "${FILESDIR}"/${PN}-2.02.129-static-pkgconfig-libs.patch #370217, #439414 + blkid
  60. "${FILESDIR}"/${PN}-2.02.130-pthread-pkgconfig.patch #492450
  61. )
  62. pkg_setup() {
  63. local CONFIG_CHECK="~SYSVIPC"
  64. if use udev; then
  65. local WARNING_SYSVIPC="CONFIG_SYSVIPC:\tis not set (required for udev sync)\n"
  66. if linux_config_exists; then
  67. local uevent_helper_path=$(linux_chkconfig_string UEVENT_HELPER_PATH)
  68. if [ -n "${uevent_helper_path}" ] && [ "${uevent_helper_path}" != '""' ]; then
  69. ewarn "It's recommended to set an empty value to the following kernel config option:"
  70. ewarn "CONFIG_UEVENT_HELPER_PATH=${uevent_helper_path}"
  71. fi
  72. fi
  73. fi
  74. check_extra_config
  75. # 1. Genkernel no longer copies /sbin/lvm blindly.
  76. if use static; then
  77. elog "Warning, we no longer overwrite /sbin/lvm and /sbin/dmsetup with"
  78. elog "their static versions. If you need the static binaries,"
  79. elog "you must append .static to the filename!"
  80. fi
  81. }
  82. src_prepare() {
  83. default
  84. sed -i \
  85. -e "1iAR = $(tc-getAR)" \
  86. -e "s:CC ?= @CC@:CC = $(tc-getCC):" \
  87. make.tmpl.in || die #444082
  88. sed -i -e '/FLAG/s:-O2::' configure{.in,} || die #480212
  89. if use udev && ! use device-mapper-only; then
  90. sed -i -e '/use_lvmetad =/s:0:1:' conf/example.conf.in || die #514196
  91. elog "Notice that \"use_lvmetad\" setting is enabled with USE=\"udev\" in"
  92. elog "/etc/lvm/lvm.conf, which will require restart of udev, lvm, and lvmetad"
  93. elog "if it was previously disabled."
  94. fi
  95. sed -i -e "s:/usr/bin/true:$(type -P true):" scripts/blk_availability_systemd_red_hat.service.in || die #517514
  96. # Without thin-privision-tools, there is nothing to install for target install_man7:
  97. use thin || { sed -i -e '/^install_lvm2/s:install_man7::' man/Makefile.in || die; }
  98. eautoreconf
  99. }
  100. src_configure() {
  101. filter-flags -flto
  102. local myconf=()
  103. local buildmode
  104. myconf+=( $(use_enable !device-mapper-only dmeventd) )
  105. myconf+=( $(use_enable !device-mapper-only cmdlib) )
  106. myconf+=( $(use_enable !device-mapper-only applib) )
  107. myconf+=( $(use_enable !device-mapper-only fsadm) )
  108. myconf+=( $(use_enable !device-mapper-only lvmetad) )
  109. use device-mapper-only && myconf+=( --disable-udev-systemd-background-jobs )
  110. # Most of this package does weird stuff.
  111. # The build options are tristate, and --without is NOT supported
  112. # options: 'none', 'internal', 'shared'
  113. if use static; then
  114. buildmode="internal"
  115. # This only causes the .static versions to become available
  116. myconf+=( --enable-static_link )
  117. else
  118. buildmode="shared"
  119. fi
  120. dmbuildmode=$(use !device-mapper-only && echo internal || echo none)
  121. # dmeventd requires mirrors to be internal, and snapshot available
  122. # so we cannot disable them
  123. myconf+=( --with-mirrors=${dmbuildmode} )
  124. myconf+=( --with-snapshots=${dmbuildmode} )
  125. if use thin; then
  126. myconf+=( --with-thin=internal --with-cache=internal )
  127. local texec
  128. for texec in check dump repair restore; do
  129. myconf+=( --with-thin-${texec}="${EPREFIX}"/sbin/thin_${texec} )
  130. myconf+=( --with-cache-${texec}="${EPREFIX}"/sbin/cache_${texec} )
  131. done
  132. else
  133. myconf+=( --with-thin=none --with-cache=none )
  134. fi
  135. if use lvm1; then
  136. myconf+=( --with-lvm1=${buildmode} )
  137. else
  138. myconf+=( --with-lvm1=none )
  139. fi
  140. # disable O_DIRECT support on hppa, breaks pv detection (#99532)
  141. use hppa && myconf+=( --disable-o_direct )
  142. if use clvm; then
  143. myconf+=( --with-cluster=${buildmode} )
  144. # 4-state! Make sure we get it right, per bug 210879
  145. # Valid options are: none, cman, gulm, all
  146. #
  147. # 2009/02:
  148. # gulm is removed now, now dual-state:
  149. # cman, none
  150. # all still exists, but is not needed
  151. #
  152. # 2009/07:
  153. # TODO: add corosync and re-enable ALL
  154. local clvmd=""
  155. use cman && clvmd="cman"
  156. #clvmd="${clvmd/cmangulm/all}"
  157. use corosync && clvmd="${clvmd:+$clvmd,}corosync"
  158. use openais && clvmd="${clvmd:+$clvmd,}openais"
  159. [ -z "${clvmd}" ] && clvmd="none"
  160. myconf+=( --with-clvmd=${clvmd} )
  161. myconf+=( --with-pool=${buildmode} )
  162. else
  163. myconf+=( --with-clvmd=none --with-cluster=none )
  164. fi
  165. econf \
  166. $(use_enable readline) \
  167. $(use_enable selinux) \
  168. --enable-pkgconfig \
  169. --with-confdir="${EPREFIX}"/etc \
  170. --exec-prefix="${EPREFIX}" \
  171. --sbindir="${EPREFIX}/sbin" \
  172. --with-staticdir="${EPREFIX}"/sbin \
  173. --libdir="${EPREFIX}/$(get_libdir)" \
  174. --with-usrlibdir="${EPREFIX}/usr/$(get_libdir)" \
  175. --with-default-dm-run-dir=/run \
  176. --with-default-run-dir=/run/lvm \
  177. --with-default-locking-dir=/run/lock/lvm \
  178. --with-default-pid-dir=/run \
  179. $(use_enable udev udev_rules) \
  180. $(use_enable udev udev_sync) \
  181. $(use_with udev udevdir "$(get_udevdir)"/rules.d) \
  182. $(use_enable systemd udev-systemd-background-jobs) \
  183. --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
  184. ${myconf[@]} \
  185. CLDFLAGS="${LDFLAGS}"
  186. }
  187. src_compile() {
  188. pushd include >/dev/null
  189. emake
  190. popd >/dev/null
  191. if use device-mapper-only ; then
  192. emake device-mapper
  193. else
  194. emake
  195. emake CC="$(tc-getCC)" -C scripts lvm2_activation_generator_systemd_red_hat
  196. fi
  197. }
  198. src_install() {
  199. local inst
  200. INSTALL_TARGETS="install install_tmpfiles_configuration"
  201. # install systemd related files only when requested, bug #522430
  202. use systemd && INSTALL_TARGETS="${INSTALL_TARGETS} install_systemd_units install_systemd_generators"
  203. use device-mapper-only && INSTALL_TARGETS="install_device-mapper"
  204. for inst in ${INSTALL_TARGETS}; do
  205. emake DESTDIR="${D}" ${inst}
  206. done
  207. newinitd "${FILESDIR}"/device-mapper.rc-2.02.105-r2 device-mapper
  208. newconfd "${FILESDIR}"/device-mapper.conf-1.02.22-r3 device-mapper
  209. if use !device-mapper-only ; then
  210. newinitd "${FILESDIR}"/dmeventd.initd-2.02.67-r1 dmeventd
  211. newinitd "${FILESDIR}"/lvm.rc-2.02.105-r2 lvm
  212. newconfd "${FILESDIR}"/lvm.confd-2.02.28-r2 lvm
  213. newinitd "${FILESDIR}"/lvm-monitoring.initd-2.02.105-r2 lvm-monitoring
  214. newinitd "${FILESDIR}"/lvmetad.initd-2.02.105-r2 lvmetad
  215. fi
  216. if use clvm; then
  217. newinitd "${FILESDIR}"/clvmd.rc-2.02.39 clvmd
  218. newconfd "${FILESDIR}"/clvmd.confd-2.02.39 clvmd
  219. fi
  220. if use static-libs; then
  221. dolib.a libdm/ioctl/libdevmapper.a
  222. dolib.a libdaemon/client/libdaemonclient.a #462908
  223. #gen_usr_ldscript libdevmapper.so
  224. dolib.a daemons/dmeventd/libdevmapper-event.a
  225. #gen_usr_ldscript libdevmapper-event.so
  226. else
  227. rm -f "${ED}"usr/$(get_libdir)/{libdevmapper-event,liblvm2cmd,liblvm2app,libdevmapper}.a
  228. fi
  229. if use lvm2create_initrd; then
  230. dosbin scripts/lvm2create_initrd/lvm2create_initrd
  231. doman scripts/lvm2create_initrd/lvm2create_initrd.8
  232. newdoc scripts/lvm2create_initrd/README README.lvm2create_initrd
  233. fi
  234. insinto /etc
  235. doins "${FILESDIR}"/dmtab
  236. dodoc README VERSION* WHATS_NEW WHATS_NEW_DM doc/*.{c,txt} conf/*.conf
  237. }
  238. pkg_postinst() {
  239. ewarn "Make sure the \"lvm\" init script is in the runlevels:"
  240. ewarn "# rc-update add lvm boot"
  241. ewarn
  242. ewarn "Make sure to enable lvmetad in /etc/lvm/lvm.conf if you want"
  243. ewarn "to enable lvm autoactivation and metadata caching."
  244. }
  245. src_test() {
  246. einfo "Tests are disabled because of device-node mucking, if you want to"
  247. einfo "run tests, compile the package and see ${S}/tests"
  248. }