udftools-1.3.ebuild 668 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils flag-o-matic
  5. DESCRIPTION="Ben Fennema's tools for packet writing and the UDF filesystem"
  6. HOMEPAGE="https://github.com/pali/udftools/ https://sourceforge.net/projects/linux-udf/"
  7. SRC_URI="https://github.com/pali/udftools/releases/download/${PV}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
  11. IUSE=""
  12. RDEPEND="sys-libs/readline:0="
  13. DEPEND="${RDEPEND}"
  14. src_install() {
  15. default
  16. newinitd "${FILESDIR}"/pktcdvd.init pktcdvd
  17. dosym mkudffs.8 /usr/share/man/man8/mkfs.udf.8
  18. }