vzquota-3.1.ebuild 816 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="OpenVZ VPS disk quota utility"
  6. HOMEPAGE="http://openvz.org/download/utils/vzquota/"
  7. SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ia64 ~ppc64 ~sparc x86"
  11. IUSE=""
  12. src_prepare() {
  13. sed -e 's,$(INSTALL) -s -m,$(INSTALL) -m,' \
  14. -e 's:$(CC) $(CFLAGS) -o:$(CC) $(CFLAGS) $(LDFLAGS) -o:' \
  15. -e 's:-Werror ::' \
  16. -i "${S}/src/Makefile" || die 'sed on src/Makefile failed'
  17. tc-export CC
  18. }
  19. src_install() {
  20. emake DESTDIR="${ED}" INSTALL="${EPREFIX}/usr/bin/install" install
  21. keepdir /var/vzquota
  22. # remove accidentally created man8 dir
  23. rm -r "${ED}/man8" || die 'remove man8 directory failed'
  24. }