wpflash-0.ebuild 531 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="flash the firmware on a Webpal"
  5. HOMEPAGE="http://webpal.bigbrd.com/"
  6. SRC_URI="http://webpal.bigbrd.com/wpflash.c"
  7. LICENSE="public-domain"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~arm ~x86"
  10. IUSE=""
  11. DEPEND=""
  12. S=${WORKDIR}
  13. src_unpack() {
  14. cp "${DISTDIR}"/${A} "${WORKDIR}"/ || die
  15. epatch "${FILESDIR}"/${PN}-gentoo.patch
  16. }
  17. src_compile() {
  18. emake wpflash || die
  19. }
  20. src_install() {
  21. dosbin wpflash || die
  22. }