db-1.85-r3.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs multilib multilib
  4. DESCRIPTION="old berk db kept around for really old packages"
  5. HOMEPAGE="http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/overview/index.html"
  6. SRC_URI="http://download.oracle.com/berkeley-db/db.${PV}.tar.gz
  7. mirror://gentoo/${PF}.1.patch.bz2"
  8. # The patch used by Gentoo is from Fedora, and includes all 5 patches found on
  9. # the Oracle page, plus others.
  10. LICENSE="Sleepycat"
  11. SLOT="1"
  12. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
  13. IUSE=""
  14. DEPEND=""
  15. S=${WORKDIR}/db.${PV}
  16. src_unpack() {
  17. unpack ${A}
  18. cd "${S}"
  19. epatch "${WORKDIR}"/${PF}.1.patch
  20. epatch "${FILESDIR}"/${P}-gentoo-paths.patch
  21. sed -i \
  22. -e "s:@GENTOO_LIBDIR@:$(get_libdir):" \
  23. PORT/linux/Makefile || die
  24. }
  25. src_compile() {
  26. tc-export CC AR RANLIB
  27. emake -C PORT/linux OORG="${CFLAGS}" || die
  28. }
  29. src_install() {
  30. make -C PORT/linux install DESTDIR="${ED}" || die
  31. # binary compat symlink
  32. dosym libdb1.so.2 /usr/$(get_libdir)/libdb.so.2 || die
  33. dosed "s:<db.h>:<db1/db.h>:" /usr/include/db1/ndbm.h
  34. dosym db1/ndbm.h /usr/include/ndbm.h
  35. dodoc changelog README
  36. newdoc hash/README README.hash
  37. docinto ps
  38. dodoc docs/*.ps
  39. }