libseccomp-2.3.2.ebuild 962 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # TODO: Add python support.
  4. EAPI="5"
  5. inherit eutils multilib-minimal
  6. DESCRIPTION="high level interface to Linux seccomp filter"
  7. HOMEPAGE="https://github.com/seccomp/libseccomp"
  8. SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz"
  9. LICENSE="LGPL-2.1"
  10. SLOT="0"
  11. KEYWORDS="-* ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~s390 ~x86"
  12. IUSE="static-libs"
  13. # We need newer kernel headers; we don't keep strict control of the exact
  14. # version here, just be safe and pull in the latest stable ones. #551248
  15. DEPEND=">=sys-kernel/linux-headers-4.3"
  16. src_prepare() {
  17. sed -i \
  18. -e '/_LDFLAGS/s:-static::' \
  19. tools/Makefile.in || die
  20. }
  21. multilib_src_configure() {
  22. ECONF_SOURCE=${S} \
  23. econf \
  24. $(use_enable static-libs static) \
  25. --disable-python
  26. }
  27. multilib_src_install_all() {
  28. find "${ED}" -name libseccomp.la -delete
  29. einstalldocs
  30. }