libservicelog-1.1.15.ebuild 592 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="Provides a library for logging service-related events"
  6. SRC_URI="mirror://sourceforge/linux-diag/${P}.tar.gz"
  7. HOMEPAGE="http://linux-diag.sourceforge.net/servicelog/"
  8. SLOT="0"
  9. LICENSE="IBM"
  10. KEYWORDS="~ppc ~ppc64"
  11. IUSE="static-libs"
  12. DEPEND="
  13. dev-db/sqlite:=
  14. sys-libs/librtas
  15. "
  16. RDEPEND="
  17. ${DEPEND}
  18. virtual/logger
  19. "
  20. DOCS=( ChangeLog )
  21. src_configure() {
  22. econf $(use_enable static-libs static)
  23. }
  24. src_install() {
  25. default
  26. prune_libtool_files
  27. }