tdb-1.3.8.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="threads"
  6. inherit waf-utils multilib-minimal python-single-r1 eutils
  7. DESCRIPTION="A simple database API"
  8. HOMEPAGE="http://tdb.samba.org/"
  9. SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
  13. IUSE="python"
  14. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  15. RDEPEND="python? ( ${PYTHON_DEPS} )"
  16. DEPEND="
  17. ${RDEPEND}
  18. ${PYTHON_DEPS}
  19. app-text/docbook-xml-dtd:4.2"
  20. WAF_BINARY="${S}/buildtools/bin/waf"
  21. src_prepare() {
  22. python_fix_shebang .
  23. multilib_copy_sources
  24. }
  25. multilib_src_configure() {
  26. local extra_opts=()
  27. if ! multilib_is_native_abi || ! use python; then
  28. extra_opts+=( --disable-python )
  29. fi
  30. waf-utils_src_configure \
  31. "${extra_opts[@]}"
  32. }
  33. multilib_src_compile() {
  34. # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
  35. unset MAKEOPTS
  36. waf-utils_src_compile
  37. }
  38. multilib_src_test() {
  39. # the default src_test runs 'make test' and 'make check', letting
  40. # the tests fail occasionally (reason: unknown)
  41. emake check
  42. }
  43. multilib_src_install() {
  44. waf-utils_src_install
  45. }