amlc-0.5.1.ebuild 559 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="Another Modeline Calculator, generates quality X11 display configs easily"
  6. HOMEPAGE="https://sourceforge.net/projects/amlc.berlios/"
  7. SRC_URI="https://dev.gentoo.org/~jer/${P}.cpp"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. S=${WORKDIR}
  12. src_prepare() {
  13. cp "${DISTDIR}"/${P}.cpp "${S}"
  14. }
  15. src_compile() {
  16. $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} ${P}.cpp -o ${PN} || die
  17. }
  18. src_install() {
  19. dobin ${PN}
  20. }