xauth-1.0.10.ebuild 620 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-utils xorg-2
  5. DESCRIPTION="X authority file utility"
  6. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
  7. IUSE="ipv6 test"
  8. RDEPEND="x11-libs/libX11
  9. x11-libs/libXau
  10. x11-libs/libXext
  11. x11-libs/libXmu"
  12. DEPEND="${RDEPEND}
  13. test? ( dev-util/cmdtest )"
  14. src_configure() {
  15. XORG_CONFIGURE_OPTIONS=(
  16. $(use_enable ipv6)
  17. )
  18. xorg-2_src_configure
  19. }
  20. src_test() {
  21. # Address sandbox failure, bug #527574
  22. addwrite /proc/self/comm
  23. autotools-utils_src_test
  24. }