xdriinfo-1.0.5.ebuild 513 B

1234567891011121314151617181920212223
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xorg-2 flag-o-matic multilib
  5. DESCRIPTION="query configuration information of DRI drivers"
  6. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
  7. IUSE=""
  8. RDEPEND="x11-libs/libX11
  9. virtual/opengl"
  10. DEPEND="${RDEPEND}
  11. x11-proto/glproto"
  12. pkg_setup() {
  13. xorg-2_pkg_setup
  14. append-cppflags "-I${EPREFIX}/usr/$(get_libdir)/opengl/xorg-x11/include/"
  15. }