1234567891011121314151617181920212223242526272829303132 |
- # Copyright 1999-2013 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit autotools-utils flag-o-matic
- DESCRIPTION="A generic touchscreen calibration program for X.Org"
- HOMEPAGE="https://www.freedesktop.org/wiki/Software/xinput_calibrator"
- SRC_URI="mirror://github/tias/${PN}/${P}.tar.gz"
- LICENSE="MIT"
- SLOT="0"
- KEYWORDS="amd64 arm x86"
- IUSE="gtk"
- DEPEND="x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXrandr
- x11-proto/inputproto
- gtk? ( dev-cpp/gtkmm:2.4 )"
- RDEPEND="${DEPEND}"
- src_configure() {
- append-cxxflags -std=c++11 #566594
- local myeconfargs=(
- --with-gui=$(use gtk && echo "gtkmm" || echo "x11")
- )
- autotools-utils_src_configure
- }
|