xinput_calibrator-0.7.5.ebuild 716 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-utils flag-o-matic
  5. DESCRIPTION="A generic touchscreen calibration program for X.Org"
  6. HOMEPAGE="https://www.freedesktop.org/wiki/Software/xinput_calibrator"
  7. SRC_URI="mirror://github/tias/${PN}/${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="amd64 arm x86"
  11. IUSE="gtk"
  12. DEPEND="x11-libs/libX11
  13. x11-libs/libXext
  14. x11-libs/libXi
  15. x11-libs/libXrandr
  16. x11-proto/inputproto
  17. gtk? ( dev-cpp/gtkmm:2.4 )"
  18. RDEPEND="${DEPEND}"
  19. src_configure() {
  20. append-cxxflags -std=c++11 #566594
  21. local myeconfargs=(
  22. --with-gui=$(use gtk && echo "gtkmm" || echo "x11")
  23. )
  24. autotools-utils_src_configure
  25. }