libGLw-8.0.0.ebuild 664 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. MY_P=glw-"${PV}"
  5. inherit autotools-utils
  6. DESCRIPTION="Mesa GLw library"
  7. HOMEPAGE="http://mesa3d.sourceforge.net/"
  8. SRC_URI="ftp://ftp.freedesktop.org/pub/mesa/glw/${MY_P}.tar.bz2"
  9. SLOT="0"
  10. LICENSE="MIT"
  11. KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
  12. IUSE="+motif static-libs"
  13. RDEPEND="
  14. !media-libs/mesa[motif]
  15. x11-libs/libX11
  16. x11-libs/libXt
  17. x11-libs/motif:0
  18. virtual/opengl"
  19. DEPEND="${RDEPEND}
  20. virtual/pkgconfig"
  21. S="${WORKDIR}"/${MY_P}
  22. src_configure() {
  23. local myeconfargs=(
  24. --enable-motif
  25. )
  26. autotools-utils_src_configure
  27. }