libXaw3dXft-1.6.2c.ebuild 732 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xorg-2
  5. DESCRIPTION="Xaw3dXft library"
  6. HOMEPAGE="https://sourceforge.net/projects/sf-xpaint"
  7. SRC_URI="mirror://sourceforge/sf-xpaint/${P}.tar.bz2"
  8. KEYWORDS="amd64 x86"
  9. IUSE="unicode xpm"
  10. RDEPEND="x11-libs/libX11
  11. x11-libs/libXext
  12. x11-libs/libXft
  13. x11-libs/libXmu
  14. x11-libs/libXt
  15. xpm? ( x11-libs/libXpm )"
  16. DEPEND="${RDEPEND}
  17. sys-devel/flex
  18. virtual/yacc
  19. x11-proto/xextproto
  20. x11-proto/xproto"
  21. pkg_setup() {
  22. XORG_CONFIGURE_OPTIONS=(
  23. $(use_enable unicode internationalization)
  24. $(usex xpm "--enable-multiplane-bitmaps" "")
  25. --enable-arrow-scrollbars
  26. --enable-gray-stipples
  27. )
  28. xorg-2_pkg_setup
  29. }