libast-0.7-r1.ebuild 954 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="LIBrary of Assorted Spiffy Things"
  5. HOMEPAGE="http://www.eterm.org/download/"
  6. SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
  10. IUSE="imlib cpu_flags_x86_mmx pcre"
  11. RDEPEND="
  12. !sci-astronomy/ast
  13. x11-libs/libXt
  14. x11-proto/xproto
  15. x11-libs/libICE
  16. x11-libs/libSM
  17. x11-libs/libX11
  18. media-libs/freetype
  19. imlib? ( media-libs/imlib2 )
  20. pcre? ( dev-libs/libpcre )"
  21. DEPEND="${RDEPEND}"
  22. DOCS=( README DESIGN ChangeLog )
  23. src_prepare() {
  24. default
  25. local myregexp="posix"
  26. use pcre && myregexp="pcre"
  27. econf \
  28. $(use_with imlib) \
  29. $(use_enable cpu_flags_x86_mmx mmx) \
  30. --with-regexp="${myregexp}"
  31. }
  32. src_install() {
  33. default
  34. emake DESTDIR="${D}" install
  35. }