libast-9999.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. #ECVS_SERVER="cvs.sourceforge.net:/cvsroot/enlightenment"
  4. ECVS_SERVER="anoncvs.enlightenment.org:/var/cvs/e"
  5. ECVS_MODULE="eterm/libast"
  6. inherit eutils cvs autotools
  7. DESCRIPTION="LIBrary of Assorted Spiffy Things"
  8. HOMEPAGE="http://www.eterm.org/download/"
  9. SRC_URI=""
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS=""
  13. IUSE="imlib cpu_flags_x86_mmx pcre"
  14. RDEPEND="!sci-astronomy/ast
  15. x11-libs/libXt
  16. x11-proto/xproto
  17. x11-libs/libICE
  18. x11-libs/libSM
  19. x11-libs/libX11
  20. =media-libs/freetype-2*
  21. imlib? ( media-libs/imlib2 )
  22. pcre? ( dev-libs/libpcre )"
  23. DEPEND="${RDEPEND}"
  24. S=${WORKDIR}/${ECVS_MODULE}
  25. src_unpack() {
  26. cvs_src_unpack
  27. cd "${S}"
  28. eautoreconf
  29. }
  30. src_compile() {
  31. local myregexp="posix"
  32. use pcre && myregexp="pcre"
  33. econf \
  34. $(use_with imlib) \
  35. $(use_enable cpu_flags_x86_mmx mmx) \
  36. --with-regexp=${myregexp} \
  37. || die
  38. emake || die
  39. }
  40. src_install() {
  41. make DESTDIR="${D}" install || die
  42. dodoc README DESIGN ChangeLog
  43. }