libtinynotify-0.2.1.ebuild 629 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools-utils
  5. DESCRIPTION="A lightweight implementation of Desktop Notification Spec"
  6. HOMEPAGE="https://github.com/mgorny/libtinynotify/"
  7. SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug doc static-libs"
  12. RDEPEND="sys-apps/dbus"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig
  15. doc? ( >=dev-util/gtk-doc-1.18 )"
  16. DOCS=( README )
  17. src_configure() {
  18. myeconfargs=(
  19. $(use_enable debug)
  20. $(use_enable doc gtk-doc)
  21. )
  22. autotools-utils_src_configure
  23. }