libvdpau-1.1.1.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. VIRTUALX_REQUIRED="test"
  5. inherit autotools-multilib flag-o-matic virtualx
  6. DESCRIPTION="VDPAU wrapper and trace libraries"
  7. HOMEPAGE="https://www.freedesktop.org/wiki/Software/VDPAU"
  8. SRC_URI="https://people.freedesktop.org/~aplattner/vdpau/${P}.tar.gz"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="~alpha amd64 x86 ~amd64-fbsd ~x86-fbsd"
  12. IUSE="doc dri"
  13. RDEPEND=">=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
  14. dri? ( >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}] )
  15. !=x11-drivers/nvidia-drivers-180*
  16. !=x11-drivers/nvidia-drivers-185*
  17. !=x11-drivers/nvidia-drivers-190*
  18. abi_x86_32? ( !app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)] )"
  19. DEPEND="${RDEPEND}
  20. virtual/pkgconfig
  21. doc? (
  22. app-doc/doxygen
  23. media-gfx/graphviz
  24. virtual/latex-base
  25. )
  26. dri? ( >=x11-proto/dri2proto-2.2 )"
  27. src_configure() {
  28. append-cppflags -D_GNU_SOURCE
  29. local myeconfargs=(
  30. --docdir="${EPREFIX}"/usr/share/doc/${PF}
  31. $(use_enable doc documentation)
  32. $(use dri || echo --disable-dri2)
  33. )
  34. autotools-multilib_src_configure
  35. }
  36. multilib_src_test() {
  37. Xemake check
  38. }
  39. src_install() {
  40. autotools-multilib_src_install
  41. prune_libtool_files --modules
  42. }