devilspie-0.22.ebuild 969 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit autotools
  5. DESCRIPTION="A Window Matching utility similar to Sawfish's Matched Windows feature"
  6. HOMEPAGE="http://www.burtonini.com/blog/computers/devilspie"
  7. SRC_URI="http://www.burtonini.com/computing/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux"
  11. IUSE=""
  12. RDEPEND="
  13. >=dev-libs/glib-2.10
  14. x11-libs/gtk+:2
  15. >=x11-libs/libwnck-2.10:1
  16. x11-libs/libX11
  17. "
  18. DEPEND="${RDEPEND}
  19. virtual/pkgconfig
  20. dev-util/intltool
  21. sys-devel/gettext
  22. gnome-base/gnome-common" # Required by eautoreconf
  23. src_prepare() {
  24. sed -i -e "s:\(/usr/share/doc/devilspie\):\1-${PVR}:" devilspie.1 || die
  25. sed -i -e '/-DG.*_DISABLE_DEPRECATED/d' src/Makefile.am || die
  26. eautoreconf
  27. export LIBS="-lX11"
  28. }
  29. src_install() {
  30. emake DESTDIR="${D}" install || die
  31. dodoc AUTHORS ChangeLog NEWS README TODO
  32. keepdir /etc/devilspie
  33. }