sct-0.3.ebuild 532 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Set color temperature of the screen"
  5. HOMEPAGE="https://www.umaxx.net/"
  6. SRC_URI="https://www.umaxx.net/dl/${P}.tar.gz"
  7. LICENSE="public-domain"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. DEPEND="x11-libs/libXrandr"
  11. RDEPEND="${DEPEND}"
  12. DOCS=( README )
  13. src_prepare() {
  14. default
  15. sed \
  16. -e 's:_BSD_SOURCE:_DEFAULT_SOURCE:g' \
  17. -i Makefile || die
  18. }
  19. src_install() {
  20. dobin "${PN}"
  21. doman "${PN}.1"
  22. einstalldocs
  23. }