xcb-2.4-r1.ebuild 966 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="Marc Lehmann's improved X Cut Buffers"
  6. HOMEPAGE="http://oldhome.schmorp.de/marc/xcb.html"
  7. SRC_URI="http://oldhome.schmorp.de/marc/data/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ~ppc x86"
  11. IUSE="motif"
  12. RDEPEND="
  13. x11-libs/libX11
  14. x11-libs/libXaw
  15. x11-libs/libXext
  16. x11-libs/libXt
  17. "
  18. DEPEND="
  19. ${RDEPEND}
  20. x11-proto/xproto
  21. motif? ( >=x11-libs/motif-2.3:0 )
  22. "
  23. src_compile() {
  24. local gui libs
  25. if use motif; then
  26. gui="-DMOTIF"
  27. libs="-lXm -lXt -lX11"
  28. else
  29. gui="-DATHENA"
  30. libs="-lXaw -lXt -lXext -lX11"
  31. fi
  32. emake \
  33. -f Makefile.std xcb Xcb.ad \
  34. CC="$(tc-getCC)" \
  35. CPP="$(tc-getCPP)" \
  36. CFLAGS="${CFLAGS} ${gui}" \
  37. GUI="${gui}" \
  38. LIBS="${libs}" \
  39. LDFLAGS="${LDFLAGS}"
  40. }
  41. src_install() {
  42. dobin xcb
  43. newman xcb.man xcb.1
  44. insinto /usr/share/X11/app-defaults
  45. newins Xcb.ad Xcb
  46. }