xssstate-1.1.ebuild 675 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="A simple tool to retrieve the X screensaver state"
  6. HOMEPAGE="http://tools.suckless.org/x/xssstate"
  7. SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND="
  13. x11-libs/libX11
  14. x11-libs/libXScrnSaver
  15. "
  16. DEPEND="
  17. ${RDEPEND}
  18. x11-proto/scrnsaverproto
  19. x11-proto/xproto
  20. "
  21. src_prepare() {
  22. epatch "${FILESDIR}"/${PN}-1.0.20130103-gentoo.patch
  23. tc-export CC
  24. }
  25. src_install() {
  26. emake DESTDIR="${D}" PREFIX='/usr' install
  27. dodoc README xsidle.sh
  28. doman ${PN}.1
  29. }