ascpu-1.11.ebuild 816 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs
  4. IUSE="jpeg"
  5. DESCRIPTION="CPU statistics monitor utility for X Windows"
  6. SRC_URI="http://www.tigr.net/afterstep/download/ascpu/${P}.tar.gz"
  7. HOMEPAGE="http://www.tigr.net"
  8. SLOT="0"
  9. LICENSE="GPL-2"
  10. KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
  11. RDEPEND="x11-libs/libXpm
  12. x11-libs/libSM
  13. jpeg? ( virtual/jpeg )"
  14. DEPEND="${RDEPEND}
  15. x11-proto/xproto"
  16. src_unpack() {
  17. unpack ${A}
  18. cd "${S}"
  19. epatch "${FILESDIR}"/${P}-gentoo.patch
  20. }
  21. src_compile() {
  22. econf $(use_enable jpeg) || die "econf failed"
  23. emake CC="$(tc-getCC)" || die "emake failed"
  24. }
  25. src_install() {
  26. dodir /usr/bin
  27. dodir /usr/share/man/man1
  28. emake DESTDIR="${D}" install || die "emake install failed"
  29. dodoc README
  30. }