asmem-1.12-r1.ebuild 778 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="Monitor the utilization level of memory, cache and swap space"
  6. HOMEPAGE="http://www.tigr.net/"
  7. SRC_URI="${HOMEPAGE}afterstep/download/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc ppc64 ~sparc x86"
  11. IUSE="jpeg"
  12. RDEPEND="x11-libs/libX11
  13. x11-libs/libICE
  14. x11-libs/libSM
  15. x11-libs/libXpm
  16. x11-libs/libXext
  17. jpeg? ( virtual/jpeg:0 )"
  18. DEPEND="${RDEPEND}
  19. x11-proto/xproto"
  20. PATCHES=( "${FILESDIR}/respect-ldflags.patch" )
  21. src_configure() {
  22. econf $(use_enable jpeg)
  23. }
  24. src_compile() {
  25. emake CC=$(tc-getCC) LDFLAGS="${LDFLAGS}"
  26. }
  27. src_install() {
  28. dobin "${PN}"
  29. newman "${PN}.man" "${PN}.1"
  30. einstalldocs
  31. }