hexchat-javascript-0.3.1.ebuild 681 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="Javascript interface for HexChat"
  6. HOMEPAGE="https://github.com/TingPing/hexchat-javascript"
  7. SRC_URI="https://github.com/TingPing/hexchat-javascript/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MPL-2.0"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="examples"
  12. RDEPEND="
  13. dev-lang/spidermonkey:0
  14. >=net-irc/hexchat-2.9.6[plugins(+)]"
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig"
  17. pkg_setup() {
  18. if [[ ${MERGE_TYPE} != binary ]]; then
  19. tc-export CXX PKG_CONFIG
  20. fi
  21. }
  22. src_install() {
  23. default
  24. if use examples ; then
  25. dodoc -r examples
  26. fi
  27. }