pidgin-sipe-1.20.1.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
  6. HOMEPAGE="http://sipe.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug kerberos ocs2005-message-hack openssl telepathy voice"
  12. RDEPEND=">=dev-libs/gmime-2.4.16
  13. dev-libs/libxml2
  14. openssl? ( dev-libs/openssl:= )
  15. !openssl? ( dev-libs/nss )
  16. kerberos? ( virtual/krb5 )
  17. voice? (
  18. >=dev-libs/glib-2.28.0
  19. >=net-libs/libnice-0.1.0
  20. media-libs/gstreamer:0.10
  21. >=net-im/pidgin-2.8.0
  22. )
  23. !voice? (
  24. >=dev-libs/glib-2.12.0:2
  25. net-im/pidgin
  26. )
  27. telepathy? (
  28. >=sys-apps/dbus-1.1.0
  29. >=dev-libs/dbus-glib-0.61
  30. >=dev-libs/glib-2.28:2
  31. >=net-libs/telepathy-glib-0.18.0
  32. )
  33. "
  34. DEPEND="dev-util/intltool
  35. virtual/pkgconfig
  36. ${RDEPEND}
  37. "
  38. src_prepare() {
  39. epatch "${FILESDIR}/${P}-fix-configure-srtp-check.patch"
  40. eautoreconf
  41. }
  42. src_configure() {
  43. econf \
  44. --enable-purple \
  45. --disable-quality-check \
  46. $(use_enable telepathy) \
  47. $(use_enable debug) \
  48. $(use_enable ocs2005-message-hack) \
  49. $(use_with kerberos krb5) \
  50. $(use_with voice vv) \
  51. $(use_enable !openssl nss) \
  52. $(use_enable openssl)
  53. }
  54. src_install() {
  55. emake install DESTDIR="${D}"
  56. dodoc AUTHORS ChangeLog NEWS TODO README
  57. }