wmblob-1.0.3.ebuild 731 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools multilib
  5. DESCRIPTION="a fancy but useless dockapp with moving blobs"
  6. HOMEPAGE="http://freshmeat.net/projects/wmblob"
  7. SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.orig.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc sparc x86"
  11. IUSE=""
  12. RDEPEND="x11-libs/gtk+:2
  13. x11-libs/libX11
  14. x11-libs/libXpm
  15. x11-libs/libXext"
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig
  18. x11-proto/xextproto
  19. x11-libs/libXt"
  20. DOCS="AUTHORS ChangeLog NEWS README doc/how_it_works"
  21. src_prepare() {
  22. sed -i \
  23. -e "s:-O2:${CFLAGS}:g" \
  24. -e "s:\$x_libraries:/usr/$(get_libdir):" \
  25. configure.ac || die
  26. eautoreconf
  27. }