wmcoincoin-2.6.3.ebuild 786 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="a dockapp for browsing dacode news and board sites"
  5. HOMEPAGE="http://hules.free.fr/wmcoincoin"
  6. SRC_URI="http://hules.free.fr/${PN}/download/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~ppc ~x86"
  10. IUSE="nls xinerama"
  11. RDEPEND="x11-libs/gtk+:2
  12. media-libs/imlib2[X]
  13. x11-libs/libXext
  14. x11-libs/libXpm
  15. x11-libs/libX11
  16. x11-libs/libXft
  17. xinerama? ( x11-libs/libXinerama )"
  18. DEPEND="${RDEPEND}
  19. x11-proto/xextproto
  20. x11-proto/xproto
  21. x11-libs/libXt
  22. virtual/pkgconfig
  23. nls? ( sys-devel/gettext )
  24. xinerama? ( x11-proto/xineramaproto )"
  25. DOCS="AUTHORS ChangeLog NEWS README"
  26. src_configure() {
  27. econf \
  28. $(use_enable nls) \
  29. $(use_enable xinerama)
  30. }