wmdate-0.7.ebuild 865 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs
  4. DESCRIPTION="yet another date-display dock application"
  5. HOMEPAGE="http://solfertje.student.utwente.nl/~dalroi/applications.php"
  6. SRC_URI="http://solfertje.student.utwente.nl/~dalroi/${PN}/files/${P}.tar.gz"
  7. LICENSE="BSD"
  8. SLOT="0"
  9. KEYWORDS="amd64 ppc ppc64 sparc x86"
  10. IUSE=""
  11. RDEPEND="<x11-libs/libdockapp-0.7
  12. x11-libs/libX11
  13. x11-libs/libXext
  14. x11-libs/libXpm"
  15. DEPEND="${RDEPEND}
  16. x11-misc/gccmakedep
  17. x11-misc/imake"
  18. src_unpack() {
  19. unpack ${A}
  20. cd "${S}"
  21. epatch "${FILESDIR}"/${PN}-ComplexProgramTargetNoMan.patch
  22. }
  23. src_compile() {
  24. xmkmf || die "xmkmf failed."
  25. emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" \
  26. LDOPTIONS="${LDFLAGS}" || die "emake failed."
  27. }
  28. src_install() {
  29. dobin ${PN}
  30. dodoc Changelog README
  31. }