wmhdplop-0.9.9-r2.ebuild 832 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit eutils multilib
  5. DESCRIPTION="a dockapp for monitoring disk activities with fancy visuals"
  6. HOMEPAGE="http://hules.free.fr/wmhdplop"
  7. SRC_URI="http://hules.free.fr/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc x86"
  11. IUSE=""
  12. RDEPEND="media-libs/imlib2[X]
  13. x11-libs/libX11
  14. x11-libs/libXext
  15. media-fonts/corefonts
  16. >=media-libs/freetype-2"
  17. DEPEND="${RDEPEND}
  18. x11-proto/xextproto"
  19. src_prepare() {
  20. epatch "${FILESDIR}"/${P}-64bit.patch
  21. sed -i -e "s:-O3 -fomit-frame-pointer -ffast-math:${CFLAGS}:" "${S}"/configure
  22. }
  23. src_configure() {
  24. econf --disable-gkrellm
  25. }
  26. src_install() {
  27. emake DESTDIR="${D}" install || die "emake install failed."
  28. dodoc AUTHORS ChangeLog NEWS README || die
  29. }