adwaita-icon-theme-3.20.ebuild 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit gnome2 versionator
  5. DESCRIPTION="GNOME default icon theme"
  6. HOMEPAGE="https://git.gnome.org/browse/adwaita-icon-theme/"
  7. SRC_URI="${SRC_URI}
  8. branding? ( http://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
  9. "
  10. LICENSE="
  11. || ( LGPL-3 CC-BY-SA-3.0 )
  12. branding? ( CC-Sampling-Plus-1.0 )
  13. "
  14. SLOT="0"
  15. IUSE="branding"
  16. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
  17. COMMON_DEPEND="
  18. >=x11-themes/hicolor-icon-theme-0.10
  19. "
  20. RDEPEND="${COMMON_DEPEND}
  21. gnome-base/librsvg:2
  22. !<x11-themes/gnome-themes-standard-3.14
  23. "
  24. DEPEND="${COMMON_DEPEND}
  25. sys-devel/gettext
  26. virtual/pkgconfig
  27. "
  28. # This ebuild does not install any binaries
  29. RESTRICT="binchecks strip"
  30. src_prepare() {
  31. if use branding; then
  32. for i in 16 22 24 32 48; do
  33. cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
  34. "${S}"/Adwaita/${i}x${i}/places/start-here.png \
  35. || die "Copying gentoo logos failed"
  36. done
  37. fi
  38. # Install cursors in the right place used in Gentoo
  39. sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
  40. -i "${S}"/Makefile.am \
  41. -i "${S}"/Makefile.in || die
  42. gnome2_src_prepare
  43. }
  44. src_configure() {
  45. gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
  46. }