fvwm-crystal-3.2.5-r1.ebuild 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils python-r1
  6. DESCRIPTION="Configurable FVWM theme with transparency and freedesktop compatible menu"
  7. HOMEPAGE="http://fvwm-crystal.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
  12. RDEPEND="${PYTHON_DEPS}
  13. >=x11-wm/fvwm-2.6.5[png]
  14. virtual/imagemagick-tools
  15. || ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
  16. || ( x11-misc/hsetroot media-gfx/feh )
  17. sys-apps/sed
  18. sys-devel/bc
  19. virtual/awk
  20. x11-apps/xwd"
  21. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  22. src_install() {
  23. emake \
  24. DESTDIR="${D}" \
  25. docdir="/usr/share/doc/${PF}" \
  26. prefix="/usr" \
  27. install
  28. python_replicate_script \
  29. "${D}/usr/bin/${PN}".{apps,wallpaper} \
  30. "${D}/usr/share/${PN}"/fvwm/scripts/FvwmMPD/*.py
  31. }
  32. pkg_postinst() {
  33. einfo
  34. einfo "After installation, execute following commands:"
  35. einfo " $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xresources ~/.Xresources"
  36. einfo " $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xsession ~/.xinitrc"
  37. einfo
  38. einfo "Many applications can extend functionality of fvwm-crystal."
  39. einfo "They are listed in ${ROOT}usr/share/doc/${PF}/INSTALL.gz."
  40. einfo
  41. einfo "Some icons fixes was committed recently."
  42. einfo "To archive the same fixes on your private icon files,"
  43. einfo "please read ${ROOT}usr/share/doc/${PF}/INSTALL.gz."
  44. einfo "This will fix the libpng warnings at stderr."
  45. einfo
  46. einfo "The color themes was updated to Fvwm InfoStore."
  47. einfo "To know how to update your custom color themes, please run"
  48. einfo " ${ROOT}usr/share/${PN}/addons/convert_colorsets"
  49. einfo ""
  50. }