greybird-1.3.4.ebuild 946 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. MY_PN=${PN/g/G}
  5. DESCRIPTION="The default theme from Xubuntu"
  6. HOMEPAGE="http://shimmerproject.org/project/greybird/ https://github.com/shimmerproject/Greybird"
  7. SRC_URI="https://github.com/shimmerproject/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. # README says "dual-licensed as GPLv2 or later and CC-BY-SA 3.0 or later"
  9. LICENSE="CC-BY-SA-3.0 GPL-2+"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
  12. IUSE="ayatana gnome"
  13. RDEPEND=">=x11-themes/gtk-engines-murrine-0.90"
  14. DEPEND=""
  15. RESTRICT="binchecks strip"
  16. src_unpack() {
  17. unpack ${A}
  18. mv ${MY_PN}-* "${S}" || die
  19. }
  20. src_install() {
  21. dodoc README
  22. rm -f README LICENSE*
  23. insinto /usr/share/themes/${MY_PN}_compact/xfwm4
  24. doins xfwm4_compact/*
  25. rm -rf xfwm4_compact
  26. use ayatana || rm -rf unity
  27. use gnome || rm -rf metacity-1
  28. insinto /usr/share/themes/${MY_PN}
  29. doins -r *
  30. }