greybird-3.18.0.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_PN=${PN/g/G}
  5. DESCRIPTION="The default theme from Xubuntu"
  6. HOMEPAGE="http://shimmerproject.org/project/greybird/ https://github.com/shimmerproject/Greybird"
  7. SRC_URI="https://github.com/shimmerproject/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. # README says "dual-licensed as GPLv2 or later and CC-BY-SA 3.0 or later"
  9. LICENSE="CC-BY-SA-3.0 GPL-2+"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
  12. # IUSE="ayatana gnome emerald"
  13. IUSE="ayatana gnome"
  14. RDEPEND="
  15. >=x11-themes/gtk-engines-murrine-0.90
  16. "
  17. RESTRICT="binchecks strip"
  18. S=${WORKDIR}/${MY_PN}-${PV}
  19. src_install() {
  20. dodoc README
  21. rm -f README LICENSE*
  22. insinto /usr/share/themes/${MY_PN}-compact/xfwm4
  23. doins xfwm4-compact/*
  24. rm -rf xfwm4-compact
  25. insinto /usr/share/themes/${MY_PN}-a11y/xfwm4
  26. doins xfwm4-a11y/*
  27. rm -rf xfwm4-a11y
  28. insinto /usr/share/themes/${MY_PN}-bright/xfce-notify-4.0
  29. doins xfce-notify-4.0_bright/*
  30. rm -rf xfce-notify-4.0_bright
  31. use ayatana || rm -rf unity
  32. use gnome || rm -rf metacity-1
  33. insinto /usr/share/themes/${MY_PN}
  34. doins -r *
  35. }