gtk-engines-rezlooks-0.6.ebuild 998 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools eutils
  5. DESCRIPTION="Rezlooks GTK+ Engine"
  6. HOMEPAGE="http://www.gnome-look.org/content/show.php?content=39179"
  7. SRC_URI="http://www.gnome-look.org/content/files/39179-rezlooks-${PV}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  11. IUSE=""
  12. RDEPEND=">=x11-libs/gtk+-2.8:2"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. S=${WORKDIR}/rezlooks-${PV}
  16. src_prepare() {
  17. # automake complains: ChangeLog missing. There however is a Changelog.
  18. # to avoid problems with case insensitive fs, move somewhere else first.
  19. mv Changelog{,.1}
  20. mv Changelog.1 ChangeLog
  21. epatch "${FILESDIR}/${PN}-0.6-glib-single-include.patch"
  22. eautoreconf # required for interix
  23. }
  24. src_configure() {
  25. econf --disable-dependency-tracking --enable-animation
  26. }
  27. src_install() {
  28. default
  29. find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
  30. }