gtk-engines-unico-1.0.3_pre20140109.ebuild 991 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=yes
  5. AUTOTOOLS_PRUNE_LIBTOOL_FILES=modules
  6. inherit autotools-multilib eutils
  7. MY_PN=${PN/gtk-engines-}
  8. MY_PV=${PV/_pre/+14.04.}
  9. MY_P=${MY_PN}_${MY_PV}
  10. DESCRIPTION="The Unico GTK+ 3.x theming engine"
  11. HOMEPAGE="https://launchpad.net/unico"
  12. SRC_URI="https://launchpad.net/ubuntu/+archive/primary/+files/${MY_P}.orig.tar.gz"
  13. LICENSE="LGPL-2.1+"
  14. SLOT="0"
  15. KEYWORDS="amd64 ~ppc ~ppc64 x86"
  16. IUSE=""
  17. RDEPEND=">=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
  18. >=x11-libs/cairo-1.10[glib,${MULTILIB_USEDEP}]
  19. >=x11-libs/gtk+-3.5.2:3[${MULTILIB_USEDEP}]"
  20. DEPEND="${RDEPEND}
  21. virtual/pkgconfig"
  22. S=${WORKDIR}/${MY_PN}-${MY_PV}
  23. src_configure() {
  24. # $(use_enable debug) controls CPPFLAGS -D_DEBUG and -DNDEBUG but they are currently
  25. # unused in the code itself.
  26. autotools-multilib_src_configure \
  27. --disable-static \
  28. --disable-debug \
  29. --disable-maintainer-flags
  30. }